summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libcpu/m68k/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'c/src/lib/libcpu/m68k/Makefile.am')
-rw-r--r--c/src/lib/libcpu/m68k/Makefile.am10
1 files changed, 10 insertions, 0 deletions
diff --git a/c/src/lib/libcpu/m68k/Makefile.am b/c/src/lib/libcpu/m68k/Makefile.am
index 1c4ec26b1e..7685204e7c 100644
--- a/c/src/lib/libcpu/m68k/Makefile.am
+++ b/c/src/lib/libcpu/m68k/Makefile.am
@@ -168,6 +168,16 @@ if mcf548x
## mcf548x/include
include_mcf548xdir = $(includedir)/mcf548x
include_mcf548x_HEADERS = mcf548x/include/mcf548x.h
+
+## mcf548x/mcdma
+noinst_PROGRAMS += mcf548x/mcdma.rel
+include_mcf548x_HEADERS += mcf548x/mcdma/MCD_progCheck.h mcf548x/mcdma/MCD_dma.h \
+ mcf548x/mcdma/MCD_tasksInit.h mcf548x/mcdma/mcdma_glue.h
+mcf548x_mcdma_rel_SOURCES = mcf548x/mcdma/MCD_dmaApi.c mcf548x/mcdma/MCD_tasksInit.c \
+ mcf548x/mcdma/MCD_tasks.c mcf548x/mcdma/mcdma_glue.c
+
+mcf548x_mcdma_rel_CPPFLAGS = $(AM_CPPFLAGS)
+mcf548x_mcdma_rel_LDFLAGS = $(RTEMS_RELLDFLAGS)
endif
include $(srcdir)/preinstall.am