summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/unix/posix/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'c/src/lib/libbsp/unix/posix/Makefile.am')
-rw-r--r--c/src/lib/libbsp/unix/posix/Makefile.am5
1 files changed, 3 insertions, 2 deletions
diff --git a/c/src/lib/libbsp/unix/posix/Makefile.am b/c/src/lib/libbsp/unix/posix/Makefile.am
index cbb74644de..436a1f4565 100644
--- a/c/src/lib/libbsp/unix/posix/Makefile.am
+++ b/c/src/lib/libbsp/unix/posix/Makefile.am
@@ -42,9 +42,10 @@ noinst_LIBRARIES =
noinst_PROGRAMS += startup.rel
startup_rel_SOURCES = startup/bspclean.c ../../shared/bsplibc.c \
startup/bspstart.c startup/setvec.c ../../shared/bootcard.c
-if !HAS_CXX
+## for now always using main.c style startup
+##if !HAS_CXX
startup_rel_SOURCES += startup/main.c
-endif
+##endif
startup_rel_CPPFLAGS = $(AM_CPPFLAGS)
startup_rel_LDFLAGS = $(RTEMS_RELLDFLAGS)