summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/unix/posix/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2007-08-01 00:49:03 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2007-08-01 00:49:03 +0000
commiteec7c441d7cd393c69824c9df2fa40ec2278c0df (patch)
tree72ab5ca3def515144b83da3120bd13a8a2974f64 /c/src/lib/libbsp/unix/posix/Makefile.am
parent2007-07-31 Joel Sherrill <joel.sherrill@OARcorp.com> (diff)
downloadrtems-eec7c441d7cd393c69824c9df2fa40ec2278c0df.tar.bz2
2007-07-31 Joel Sherrill <joel.sherrill@OARcorp.com>
* Makefile.am, preinstall.am: You need main() to link all applications. There is no C++ specific way to link currently.
Diffstat (limited to 'c/src/lib/libbsp/unix/posix/Makefile.am')
-rw-r--r--c/src/lib/libbsp/unix/posix/Makefile.am5
1 files changed, 3 insertions, 2 deletions
diff --git a/c/src/lib/libbsp/unix/posix/Makefile.am b/c/src/lib/libbsp/unix/posix/Makefile.am
index cbb74644de..436a1f4565 100644
--- a/c/src/lib/libbsp/unix/posix/Makefile.am
+++ b/c/src/lib/libbsp/unix/posix/Makefile.am
@@ -42,9 +42,10 @@ noinst_LIBRARIES =
noinst_PROGRAMS += startup.rel
startup_rel_SOURCES = startup/bspclean.c ../../shared/bsplibc.c \
startup/bspstart.c startup/setvec.c ../../shared/bootcard.c
-if !HAS_CXX
+## for now always using main.c style startup
+##if !HAS_CXX
startup_rel_SOURCES += startup/main.c
-endif
+##endif
startup_rel_CPPFLAGS = $(AM_CPPFLAGS)
startup_rel_LDFLAGS = $(RTEMS_RELLDFLAGS)