summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/unix/posix/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'c/src/lib/libbsp/unix/posix/Makefile.am')
-rw-r--r--c/src/lib/libbsp/unix/posix/Makefile.am6
1 files changed, 3 insertions, 3 deletions
diff --git a/c/src/lib/libbsp/unix/posix/Makefile.am b/c/src/lib/libbsp/unix/posix/Makefile.am
index e8bf246915..cb46be7be7 100644
--- a/c/src/lib/libbsp/unix/posix/Makefile.am
+++ b/c/src/lib/libbsp/unix/posix/Makefile.am
@@ -4,6 +4,8 @@
ACLOCAL_AMFLAGS = -I ../../../../aclocal
+EXEEXT =
+
# wrapup is the one that actually builds and installs the library
# from the individual .rel files built in other directories
SUBDIRS = . tools
@@ -22,8 +24,6 @@ noinst_DATA =
nodist_include_HEADERS += ../../shared/include/coverhd.h
-AM_CFLAGS += $(LIBC_DEFINES)
-
project_lib_DATA =
if HAS_CXX
@@ -45,7 +45,7 @@ EXTRA_PROGRAMS += startup.rel
CLEANFILES += startup.rel
startup_rel_SOURCES = startup/bspclean.c ../../shared/bsplibc.c \
startup/bspstart.c startup/setvec.c
-if HAS_CXX
+if !HAS_CXX
startup_rel_SOURCES += startup/main.c
endif