summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/unix/posix/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'c/src/lib/libbsp/unix/posix/Makefile.am')
-rw-r--r--c/src/lib/libbsp/unix/posix/Makefile.am42
1 files changed, 13 insertions, 29 deletions
diff --git a/c/src/lib/libbsp/unix/posix/Makefile.am b/c/src/lib/libbsp/unix/posix/Makefile.am
index 9bbc4bd759..979d22c8e4 100644
--- a/c/src/lib/libbsp/unix/posix/Makefile.am
+++ b/c/src/lib/libbsp/unix/posix/Makefile.am
@@ -27,45 +27,29 @@ DISTCLEANFILES = include/bspopts.h
nodist_include_HEADERS += ../../shared/include/coverhd.h
project_lib_DATA =
-noinst_LIBRARIES =
-## if HAS_CXX
-## noinst_LIBRARIES += librtemscxx.a
-##
-## librtemscxx_a_SOURCES = startup/no-ctor.c
-##
-## # Install as a separate .$(OBJEXT)
-## project_lib_DATA += no-ctor.$(OBJEXT)
-##
-## # We install the RTEMS constructor as a separate .$(OBJEXT)
-## # so it can be easily place correctly by the compiler config file.
-## project_lib_DATA += rtems-ctor.$(OBJEXT)
-## endif
+noinst_LIBRARIES = libbsp.a
+libbsp_a_SOURCES =
-startup_SOURCES = startup/bspclean.c ../../shared/bsplibc.c \
+# startup
+libbsp_a_SOURCES += startup/bspclean.c ../../shared/bsplibc.c \
../../shared/bsppredriverhook.c ../../shared/bsppretaskinghook.c \
startup/bspstart.c startup/bsppost.c startup/bspgetworkarea.c \
startup/setvec.c ../../shared/bootcard.c
-## for now always using main.c style startup
-##if !HAS_CXX
-startup_SOURCES += startup/main.c
-##endif
+libbsp_a_SOURCES += startup/main.c
-clock_SOURCES = clock/clock.c
-console_SOURCES = console/console.c console/console-io.c
-timer_SOURCES = timer/timer.c
+# clock
+libbsp_a_SOURCES += clock/clock.c
+# console
+libbsp_a_SOURCES += console/console.c console/console-io.c
+# timer
+libbsp_a_SOURCES += timer/timer.c
if HAS_MP
-shmsupp_SOURCES = shmsupp/addrconv.c shmsupp/getcfg.c \
+# shmsupp
+libbsp_a_SOURCES += shmsupp/addrconv.c shmsupp/getcfg.c \
shmsupp/cause_intr.c shmsupp/lock.c shmsupp/mpisr.c
endif
-noinst_LIBRARIES += libbsp.a
-libbsp_a_SOURCES = $(startup_SOURCES) $(clock_SOURCES) \
- $(console_SOURCES) $(timer_SOURCES) $(shmsupp_SOURCES)
-## if HAS_CXX
-## libbsp_a_SOURCES += startup/rtems-ctor.cc
-## endif
-
EXTRA_DIST = times
include $(srcdir)/preinstall.am