summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/sparc/erc32/startup/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'c/src/lib/libbsp/sparc/erc32/startup/Makefile.am')
-rw-r--r--c/src/lib/libbsp/sparc/erc32/startup/Makefile.am9
1 files changed, 6 insertions, 3 deletions
diff --git a/c/src/lib/libbsp/sparc/erc32/startup/Makefile.am b/c/src/lib/libbsp/sparc/erc32/startup/Makefile.am
index e7f6bb05ea..b9784d9030 100644
--- a/c/src/lib/libbsp/sparc/erc32/startup/Makefile.am
+++ b/c/src/lib/libbsp/sparc/erc32/startup/Makefile.am
@@ -4,7 +4,7 @@
AUTOMAKE_OPTIONS = foreign 1.4
-VPATH = @srcdir@:@srcdir@/../../../shared
+VPATH = @srcdir@:@srcdir@/../../shared:@srcdir@/../../../shared
PGM = $(ARCH)/startup.rel
@@ -12,7 +12,10 @@ C_FILES = bspclean.c bsplibc.c bsppost.c bspstart.c main.c bootcard.c sbrk.c \
setvec.c spurious.c
C_O_FILES = $(C_FILES:%.c=$(ARCH)/%.o)
-OBJS = $(C_O_FILES)
+S_FILES = boardinit.S
+S_O_FILES = $(S_FILES:%.S=$(ARCH)/%.o)
+
+OBJS = $(C_O_FILES) $(S_O_FILES)
include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
include $(top_srcdir)/../../../../../../automake/compile.am
@@ -37,6 +40,6 @@ all-local: $(ARCH) $(OBJS) $(PGM) $(TMPINSTALL_FILES)
.PRECIOUS: $(PGM)
-EXTRA_DIST = bspclean.c bspstart.c linkcmds setvec.c spurious.c
+EXTRA_DIST = linkcmds setvec.c spurious.c boardinit.S
include $(top_srcdir)/../../../../../../automake/local.am