summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/sparc/erc32/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'c/src/lib/libbsp/sparc/erc32/Makefile.am')
-rw-r--r--c/src/lib/libbsp/sparc/erc32/Makefile.am16
1 files changed, 12 insertions, 4 deletions
diff --git a/c/src/lib/libbsp/sparc/erc32/Makefile.am b/c/src/lib/libbsp/sparc/erc32/Makefile.am
index 0cbe8e940d..2b1ba36cfc 100644
--- a/c/src/lib/libbsp/sparc/erc32/Makefile.am
+++ b/c/src/lib/libbsp/sparc/erc32/Makefile.am
@@ -5,13 +5,21 @@
ACLOCAL_AMFLAGS = -I ../../../../aclocal
# wrapup is the one that actually builds and installs the library
-# from the individual .rel files built in other directories
-SUBDIRS = . include start startup gnatsupp console clock timer erc32sonic \
- wrapup tools
+# from the individual .rel files built in other directories
+SUBDIRS = . start startup gnatsupp console clock timer erc32sonic wrapup \
+ tools
include $(top_srcdir)/../../bsp.am
-EXTRA_DIST = bsp_specs times
+include_HEADERS += include/erc32.h
+
+all-local: $(PREINSTALL_FILES)
+
+EXTRA_DIST = times
+
+$(PROJECT_INCLUDE)/erc32.h: include/erc32.h
+ $(INSTALL_DATA) $< $@
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/erc32.h
include $(top_srcdir)/../../../../automake/subdirs.am
include $(top_srcdir)/../../../../automake/local.am