summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/sh/simsh4/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'c/src/lib/libbsp/sh/simsh4/Makefile.am')
-rw-r--r--c/src/lib/libbsp/sh/simsh4/Makefile.am22
1 files changed, 19 insertions, 3 deletions
diff --git a/c/src/lib/libbsp/sh/simsh4/Makefile.am b/c/src/lib/libbsp/sh/simsh4/Makefile.am
index 0318484218..e12322462e 100644
--- a/c/src/lib/libbsp/sh/simsh4/Makefile.am
+++ b/c/src/lib/libbsp/sh/simsh4/Makefile.am
@@ -5,8 +5,8 @@
ACLOCAL_AMFLAGS = -I ../../../../aclocal
## wrapup is the one that actually builds and installs the library
-## from the individual .rel files built in other directories
-SUBDIRS = include start startup console clock timer wrapup
+## from the individual .rel files built in other directories
+SUBDIRS = . start startup console clock timer wrapup
SUBDIRS += tools
# FIXME: This directory is missing
@@ -14,7 +14,23 @@ SUBDIRS += tools
include $(top_srcdir)/../../bsp.am
-EXTRA_DIST = bsp_specs
+include_HEADERS += include/syscall.h
+include_HEADERS += include/ramdisk.h
+include_HEADERS += include/coverhd.h
+
+all-local: $(PREINSTALL_FILES)
+
+$(PROJECT_INCLUDE)/syscall.h: include/syscall.h
+ $(INSTALL_DATA) $< $@
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/syscall.h
+
+$(PROJECT_INCLUDE)/ramdisk.h: include/ramdisk.h
+ $(INSTALL_DATA) $< $@
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/ramdisk.h
+
+$(PROJECT_INCLUDE)/coverhd.h: include/coverhd.h
+ $(INSTALL_DATA) $< $@
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/coverhd.h
include $(top_srcdir)/../../../../automake/subdirs.am
include $(top_srcdir)/../../../../automake/local.am