summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/sh/shsim/startup/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'c/src/lib/libbsp/sh/shsim/startup/Makefile.am')
-rw-r--r--c/src/lib/libbsp/sh/shsim/startup/Makefile.am14
1 files changed, 6 insertions, 8 deletions
diff --git a/c/src/lib/libbsp/sh/shsim/startup/Makefile.am b/c/src/lib/libbsp/sh/shsim/startup/Makefile.am
index 7089c0c96c..5334669506 100644
--- a/c/src/lib/libbsp/sh/shsim/startup/Makefile.am
+++ b/c/src/lib/libbsp/sh/shsim/startup/Makefile.am
@@ -22,18 +22,16 @@ include $(top_srcdir)/../../../../automake/lib.am
$(PGM): $(OBJS)
$(make-rel)
-bsplib_DATA = linkcmds
-
-$(PROJECT_RELEASE)/lib/linkcmds: linkcmds
- $(INSTALL_DATA) $< $@
+project_lib_DATA = linkcmds
# the .rel file built here will be put into libbsp.a by ../wrapup/Makefile
-TMPINSTALL_FILES += $(PROJECT_RELEASE)/lib/linkcmds
-
-all-local: $(OBJS) $(PGM) $(TMPINSTALL_FILES)
-.PRECIOUS: $(PGM)
+all-local: $(PGM) $(TMPINSTALL_FILES)
EXTRA_DIST = bspstart.c linkcmds
+${PROJECT_RELEASE}/lib/linkcmds: linkcmds ${PROJECT_RELEASE}/lib/$(dirstamp)
+ $(INSTALL_DATA) $< ${PROJECT_RELEASE}/lib/linkcmds
+TMPINSTALL_FILES += ${PROJECT_RELEASE}/lib/linkcmds
+
include $(top_srcdir)/../../../../automake/local.am