summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/sh/shsim/scitab/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'c/src/lib/libbsp/sh/shsim/scitab/Makefile.am')
-rw-r--r--c/src/lib/libbsp/sh/shsim/scitab/Makefile.am36
1 files changed, 36 insertions, 0 deletions
diff --git a/c/src/lib/libbsp/sh/shsim/scitab/Makefile.am b/c/src/lib/libbsp/sh/shsim/scitab/Makefile.am
new file mode 100644
index 0000000000..bf1550749a
--- /dev/null
+++ b/c/src/lib/libbsp/sh/shsim/scitab/Makefile.am
@@ -0,0 +1,36 @@
+##
+## $Id$
+##
+
+AUTOMAKE_OPTIONS = foreign 1.4
+
+PGM = $(ARCH)/scitab.rel
+
+C_FILES = scitab.c
+C_O_FILES = $(C_FILES:%.c=$(ARCH)/%.o)
+
+OBJS = $(C_O_FILES)
+
+include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
+include $(top_srcdir)/../../../../../../automake/compile.am
+include $(top_srcdir)/../../../../../../automake/lib.am
+
+SHGEN = $(PROJECT_TOPdir)/tools/cpu/sh/shgen
+
+#
+# (OPTIONAL) Add local stuff here using +=
+#
+
+CLEANFILES = scitab.c
+
+$(PGM): $(OBJS)
+ $(make-rel)
+
+scitab.c: $(SHGEN)
+ $(SHGEN) -H $(CPU_CLOCK_RATE_HZ) sci > $@
+
+all-local: $(ARCH) $(OBJS) $(PGM)
+
+.PRECIOUS: $(PGM)
+
+include $(top_srcdir)/../../../../../../automake/local.am