summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/sh/shsim/console/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'c/src/lib/libbsp/sh/shsim/console/Makefile.am')
-rw-r--r--c/src/lib/libbsp/sh/shsim/console/Makefile.am16
1 files changed, 6 insertions, 10 deletions
diff --git a/c/src/lib/libbsp/sh/shsim/console/Makefile.am b/c/src/lib/libbsp/sh/shsim/console/Makefile.am
index 01cc97d615..563ae4cc64 100644
--- a/c/src/lib/libbsp/sh/shsim/console/Makefile.am
+++ b/c/src/lib/libbsp/sh/shsim/console/Makefile.am
@@ -4,17 +4,14 @@
AUTOMAKE_OPTIONS = foreign 1.4
-VPATH = @srcdir@:@srcdir@/../../../shared
+VPATH = @srcdir@:@srcdir@/../../shared
PGM = $(ARCH)/console.rel
-C_FILES = console-io.c console-polled.c
-C_O_FILES = $(C_FILES:%.c=$(ARCH)/%.o)
+C_FILES = console.c
+C_O_FILES = $(C_FILES:shared/%.c=$(ARCH)/%.o)
-S_FILES = console-support.S
-S_O_FILES = $(S_FILES:%.S=$(ARCH)/%.o)
-
-OBJS = $(C_O_FILES) $(S_O_FILES)
+OBJS = $(C_O_FILES)
include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
include $(top_srcdir)/../../../../../../automake/compile.am
@@ -27,12 +24,11 @@ include $(top_srcdir)/../../../../../../automake/lib.am
$(PGM): $(OBJS)
$(make-rel)
-# the .rel file built here will be put into libbsp.a by ../wrapup/Makefile
+# the .rel file built here will be put into libbsp.a by
+# ../wrapup/Makefile
all-local: $(ARCH) $(OBJS) $(PGM)
.PRECIOUS: $(PGM)
-EXTRA_DIST = console.c
-
include $(top_srcdir)/../../../../../../automake/local.am