summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/sh/shsim/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'c/src/lib/libbsp/sh/shsim/Makefile.am')
-rw-r--r--c/src/lib/libbsp/sh/shsim/Makefile.am23
1 files changed, 19 insertions, 4 deletions
diff --git a/c/src/lib/libbsp/sh/shsim/Makefile.am b/c/src/lib/libbsp/sh/shsim/Makefile.am
index aceea0a932..e1dbf1e3b6 100644
--- a/c/src/lib/libbsp/sh/shsim/Makefile.am
+++ b/c/src/lib/libbsp/sh/shsim/Makefile.am
@@ -4,16 +4,27 @@
ACLOCAL_AMFLAGS = -I ../../../../aclocal
+include $(top_srcdir)/../../../../automake/compile.am
+include $(top_srcdir)/../../bsp.am
+
# wrapup is the one that actually builds and installs the library
# from the individual .rel files built in other directories
-SUBDIRS = . start startup clock scitab gdbsci console wrapup
-
-include $(top_srcdir)/../../bsp.am
+SUBDIRS = . startup clock scitab gdbsci console wrapup
include_HEADERS += include/gdbsci.h
nodist_include_HEADERS += $(top_srcdir)/../../shared/include/coverhd.h
-all-local: $(PREINSTALL_FILES)
+S_FILES = start/start.S
+$(ARCH)/%$(LIB_VARIANT).$(OBJEXT): start/start.S $(ARCH)/$(dirstamp)
+ ${CCASCOMPILE} -DASM -o $@ -c $<
+
+project_lib_DATA = $(ARCH)/start$(LIB_VARIANT).$(OBJEXT)
+
+all-local: $(PREINSTALL_FILES) $(TMPINSTALL_FILES)
+
+EXTRA_DIST = $(S_FILES)
+
+TMPINSTALL_FILES =
$(PROJECT_INCLUDE)/gdbsci.h: include/gdbsci.h $(PROJECT_INCLUDE)/$(dirstamp)
$(INSTALL_DATA) $< $(PROJECT_INCLUDE)/gdbsci.h
@@ -23,5 +34,9 @@ $(PROJECT_INCLUDE)/coverhd.h: $(top_srcdir)/../../shared/include/coverhd.h $(PRO
$(INSTALL_DATA) $< $(PROJECT_INCLUDE)/coverhd.h
PREINSTALL_FILES += $(PROJECT_INCLUDE)/coverhd.h
+$(PROJECT_LIB)/start$(LIB_VARIANT).$(OBJEXT): $(ARCH)/start$(LIB_VARIANT).$(OBJEXT) $(PROJECT_LIB)/$(dirstamp)
+ $(INSTALL_DATA) $< $(PROJECT_LIB)/start$(LIB_VARIANT).$(OBJEXT)
+TMPINSTALL_FILES += $(PROJECT_LIB)/start$(LIB_VARIANT).$(OBJEXT)
+
include $(top_srcdir)/../../../../automake/subdirs.am
include $(top_srcdir)/../../../../automake/local.am