summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/sh/gensh4/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'c/src/lib/libbsp/sh/gensh4/Makefile.am')
-rw-r--r--c/src/lib/libbsp/sh/gensh4/Makefile.am19
1 files changed, 16 insertions, 3 deletions
diff --git a/c/src/lib/libbsp/sh/gensh4/Makefile.am b/c/src/lib/libbsp/sh/gensh4/Makefile.am
index 9d2ee17ae8..3f8e4d22bd 100644
--- a/c/src/lib/libbsp/sh/gensh4/Makefile.am
+++ b/c/src/lib/libbsp/sh/gensh4/Makefile.am
@@ -5,12 +5,25 @@
ACLOCAL_AMFLAGS = -I ../../../../aclocal
## wrapup is the one that actually builds and installs the library
-## from the individual .rel files built in other directories
-SUBDIRS = include start startup console hw_init wrapup
+## from the individual .rel files built in other directories
+SUBDIRS = . start startup console hw_init wrapup
include $(top_srcdir)/../../bsp.am
-EXTRA_DIST = bsp_specs times
+include_HEADERS += include/sdram.h
+include_HEADERS += include/coverhd.h
+
+all-local: $(PREINSTALL_FILES)
+
+EXTRA_DIST = times
+
+$(PROJECT_INCLUDE)/sdram.h: include/sdram.h
+ $(INSTALL_DATA) $< $@
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/sdram.h
+
+$(PROJECT_INCLUDE)/coverhd.h: include/coverhd.h
+ $(INSTALL_DATA) $< $@
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/coverhd.h
include $(top_srcdir)/../../../../automake/subdirs.am
include $(top_srcdir)/../../../../automake/local.am