summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/sh/gensh1/startup/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'c/src/lib/libbsp/sh/gensh1/startup/Makefile.am')
-rw-r--r--c/src/lib/libbsp/sh/gensh1/startup/Makefile.am15
1 files changed, 6 insertions, 9 deletions
diff --git a/c/src/lib/libbsp/sh/gensh1/startup/Makefile.am b/c/src/lib/libbsp/sh/gensh1/startup/Makefile.am
index 3b6aa640b8..efab58018c 100644
--- a/c/src/lib/libbsp/sh/gensh1/startup/Makefile.am
+++ b/c/src/lib/libbsp/sh/gensh1/startup/Makefile.am
@@ -22,17 +22,14 @@ include $(top_srcdir)/../../../../automake/lib.am
$(PGM): $(OBJS)
$(make-rel)
-bsplib_DATA = linkcmds
+project_lib_DATA = linkcmds
-$(PROJECT_RELEASE)/lib/linkcmds: linkcmds
- $(INSTALL_DATA) $< $@
-
-TMPINSTALL_FILES += $(PROJECT_RELEASE)/lib/linkcmds
-
-all-local: $(OBJS) $(PGM) $(TMPINSTALL_FILES)
-
-.PRECIOUS: $(PGM)
+all-local: $(PGM) $(TMPINSTALL_FILES)
EXTRA_DIST = bspclean.c bspstart.c linkcmds
+${PROJECT_RELEASE}/lib/linkcmds: linkcmds ${PROJECT_RELEASE}/lib/$(dirstamp)
+ $(INSTALL_DATA) $< ${PROJECT_RELEASE}/lib/linkcmds
+TMPINSTALL_FILES += ${PROJECT_RELEASE}/lib/linkcmds
+
include $(top_srcdir)/../../../../automake/local.am