summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/powerpc/tqm8xx/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'c/src/lib/libbsp/powerpc/tqm8xx/Makefile.am')
-rw-r--r--c/src/lib/libbsp/powerpc/tqm8xx/Makefile.am11
1 files changed, 7 insertions, 4 deletions
diff --git a/c/src/lib/libbsp/powerpc/tqm8xx/Makefile.am b/c/src/lib/libbsp/powerpc/tqm8xx/Makefile.am
index a9690269ec..a804b9244c 100644
--- a/c/src/lib/libbsp/powerpc/tqm8xx/Makefile.am
+++ b/c/src/lib/libbsp/powerpc/tqm8xx/Makefile.am
@@ -23,18 +23,21 @@ include_bsp_HEADERS = include/tqm.h include/8xx_immap.h \
../../shared/include/irq-info.h \
spi/spi.h
-noinst_LIBRARIES = libbspstart.a
-libbspstart_a_SOURCES = start/start.S
+EXTRA_DIST += start/start.S
+start.$(OBJEXT): start/start.S
+ $(CPPASCOMPILE) -o $@ -c $<
project_lib_DATA = start.$(OBJEXT)
-libbspstart_a_SOURCES += ../../powerpc/shared/start/rtems_crti.S
+EXTRA_DIST += ../../powerpc/shared/start/rtems_crti.S
+rtems_crti.$(OBJEXT): ../../powerpc/shared/start/rtems_crti.S
+ $(CPPASCOMPILE) -o $@ -c $<
project_lib_DATA += rtems_crti.$(OBJEXT)
project_lib_DATA += startup/linkcmds
dist_project_lib_DATA += startup/linkcmds.base
EXTRA_DIST += startup/linkcmds.tqm8xx
-noinst_LIBRARIES += libbsp.a
+noinst_LIBRARIES = libbsp.a
libbsp_a_SOURCES =
# irq