summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/powerpc/psim/wrapup/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'c/src/lib/libbsp/powerpc/psim/wrapup/Makefile.am')
-rw-r--r--c/src/lib/libbsp/powerpc/psim/wrapup/Makefile.am12
1 files changed, 1 insertions, 11 deletions
diff --git a/c/src/lib/libbsp/powerpc/psim/wrapup/Makefile.am b/c/src/lib/libbsp/powerpc/psim/wrapup/Makefile.am
index 2c9a3fbf7d..e82d6c8aeb 100644
--- a/c/src/lib/libbsp/powerpc/psim/wrapup/Makefile.am
+++ b/c/src/lib/libbsp/powerpc/psim/wrapup/Makefile.am
@@ -6,25 +6,15 @@ include $(top_srcdir)/../../../../automake/compile.am
include $(top_srcdir)/../../../../automake/lib.am
if HAS_MP
-GENERIC_MP_REL_PIECES = shmdr
-endif
-GENERIC_PIECES = $(GENERIC_MP_REL_PIECES)
-
-if HAS_MP
BSP_MP_O_PIECES = shmsupp
endif
BSP_PIECES = startup clock console timer vectors $(BSP_MP_O_PIECES)
# bummer; have to use $foreach since % pattern subst rules only replace 1x
OBJS = $(foreach piece, $(BSP_PIECES), ../$(piece)/$(ARCH)/*.$(OBJEXT)) \
- ../@exceptions@/$(ARCH)/rtems-cpu.rel $(foreach piece, \
- $(GENERIC_PIECES), ../../../$(piece)/$(ARCH)/$(piece).rel)
+ ../@exceptions@/$(ARCH)/rtems-cpu.rel
LIB = $(ARCH)/libbsp.a
-#
-# (OPTIONAL) Add local stuff here using +=
-#
-
$(LIB): $(OBJS)
$(make-library)