summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/powerpc/psim/startup/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'c/src/lib/libbsp/powerpc/psim/startup/Makefile.am')
-rw-r--r--c/src/lib/libbsp/powerpc/psim/startup/Makefile.am21
1 files changed, 9 insertions, 12 deletions
diff --git a/c/src/lib/libbsp/powerpc/psim/startup/Makefile.am b/c/src/lib/libbsp/powerpc/psim/startup/Makefile.am
index 40a181d2db..39c58d2c3e 100644
--- a/c/src/lib/libbsp/powerpc/psim/startup/Makefile.am
+++ b/c/src/lib/libbsp/powerpc/psim/startup/Makefile.am
@@ -22,21 +22,18 @@ include $(top_srcdir)/../../../../automake/lib.am
$(PGM): $(OBJS)
$(make-rel)
-bsplib_DATA = linkcmds device-tree
+project_lib_DATA = linkcmds device-tree
-$(PROJECT_RELEASE)/lib/linkcmds: linkcmds
- $(INSTALL_DATA) $< $@
+all-local: $(PGM) $(TMPINSTALL_FILES)
-$(PROJECT_RELEASE)/lib/device-tree: device-tree
- $(INSTALL_DATA) $< $@
-
-TMPINSTALL_FILES += $(PROJECT_RELEASE)/lib/linkcmds \
- $(PROJECT_RELEASE)/lib/device-tree
-
-all-local: $(OBJS) $(PGM) $(TMPINSTALL_FILES)
+EXTRA_DIST = bspclean.c bspstart.c device-tree linkcmds setvec.c
-.PRECIOUS: $(PGM)
+${PROJECT_RELEASE}/lib/linkcmds: linkcmds ${PROJECT_RELEASE}/lib/$(dirstamp)
+ $(INSTALL_DATA) $< ${PROJECT_RELEASE}/lib/linkcmds
+TMPINSTALL_FILES += ${PROJECT_RELEASE}/lib/linkcmds
-EXTRA_DIST = bspclean.c bspstart.c device-tree linkcmds setvec.c
+${PROJECT_RELEASE}/lib/device-tree: device-tree ${PROJECT_RELEASE}/lib/$(dirstamp)
+ $(INSTALL_DATA) $< ${PROJECT_RELEASE}/lib/device-tree
+TMPINSTALL_FILES += ${PROJECT_RELEASE}/lib/device-tree
include $(top_srcdir)/../../../../automake/local.am