summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/powerpc/psim/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'c/src/lib/libbsp/powerpc/psim/Makefile.am')
-rw-r--r--c/src/lib/libbsp/powerpc/psim/Makefile.am15
1 files changed, 10 insertions, 5 deletions
diff --git a/c/src/lib/libbsp/powerpc/psim/Makefile.am b/c/src/lib/libbsp/powerpc/psim/Makefile.am
index f05e968e55..8292a61a0c 100644
--- a/c/src/lib/libbsp/powerpc/psim/Makefile.am
+++ b/c/src/lib/libbsp/powerpc/psim/Makefile.am
@@ -5,14 +5,19 @@
ACLOCAL_AMFLAGS = -I ../../../../aclocal
# wrapup is the one that actually builds and installs the library
-# from the individual .rel files built in other directories
-SUBDIRS = include start clock console startup shmsupp timer vectors \
- @exceptions@ wrapup \
- tools
+# from the individual .rel files built in other directories
+SUBDIRS = . start clock console startup shmsupp timer vectors @exceptions@ \
+ wrapup tools
include $(top_srcdir)/../../bsp.am
-EXTRA_DIST = bsp_specs
+include_HEADERS += include/coverhd.h
+
+all-local: $(PREINSTALL_FILES)
+
+$(PROJECT_INCLUDE)/coverhd.h: include/coverhd.h
+ $(INSTALL_DATA) $< $@
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/coverhd.h
include $(top_srcdir)/../../../../automake/subdirs.am
include $(top_srcdir)/../../../../automake/local.am