summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/powerpc/ppcn_60x/startup/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'c/src/lib/libbsp/powerpc/ppcn_60x/startup/Makefile.am')
-rw-r--r--c/src/lib/libbsp/powerpc/ppcn_60x/startup/Makefile.am15
1 files changed, 6 insertions, 9 deletions
diff --git a/c/src/lib/libbsp/powerpc/ppcn_60x/startup/Makefile.am b/c/src/lib/libbsp/powerpc/ppcn_60x/startup/Makefile.am
index e61947590c..cddef27cbc 100644
--- a/c/src/lib/libbsp/powerpc/ppcn_60x/startup/Makefile.am
+++ b/c/src/lib/libbsp/powerpc/ppcn_60x/startup/Makefile.am
@@ -31,18 +31,15 @@ STARTUP_C_PIECES = bspstart bspclean sbrk setvec spurious genpvec swap main \
$(PGM): $(OBJS)
$(make-rel)
-bsplib_DATA = linkcmds
+project_lib_DATA = linkcmds
-$(PROJECT_RELEASE)/lib/linkcmds: linkcmds
- $(INSTALL_DATA) $< $@
-
-TMPINSTALL_FILES += $(PROJECT_RELEASE)/lib/linkcmds
-
-all-local: $(OBJS) $(PGM) $(TMPINSTALL_FILES)
-
-.PRECIOUS: $(PGM)
+all-local: $(PGM) $(TMPINSTALL_FILES)
EXTRA_DIST = bspclean.c bspstart.c bsptrap.S genpvec.c linkcmds \
rtems-ctor.cc setvec.c spurious.c swap.c
+${PROJECT_RELEASE}/lib/linkcmds: linkcmds ${PROJECT_RELEASE}/lib/$(dirstamp)
+ $(INSTALL_DATA) $< ${PROJECT_RELEASE}/lib/linkcmds
+TMPINSTALL_FILES += ${PROJECT_RELEASE}/lib/linkcmds
+
include $(top_srcdir)/../../../../automake/local.am