summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/powerpc/helas403/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'c/src/lib/libbsp/powerpc/helas403/Makefile.am')
-rw-r--r--c/src/lib/libbsp/powerpc/helas403/Makefile.am21
1 files changed, 15 insertions, 6 deletions
diff --git a/c/src/lib/libbsp/powerpc/helas403/Makefile.am b/c/src/lib/libbsp/powerpc/helas403/Makefile.am
index 21ffb29a12..634d46a9f4 100644
--- a/c/src/lib/libbsp/powerpc/helas403/Makefile.am
+++ b/c/src/lib/libbsp/powerpc/helas403/Makefile.am
@@ -5,17 +5,26 @@
ACLOCAL_AMFLAGS = -I ../../../../aclocal
# wrapup is the one that actually builds and installs the library
-# from the individual .rel files built in other directories
-SUBDIRS = include dlentry flashentry startup @exceptions@ wrapup
+# from the individual .rel files built in other directories
+SUBDIRS = . dlentry flashentry startup @exceptions@ wrapup
include $(top_srcdir)/../../bsp.am
-$(PROJECT_RELEASE)/lib/bsp_specs.dl: bsp_specs.dl
- $(INSTALL_DATA) $< $@
+dist_bsplib_DATA += bsp_specs.dl
+
+include_HEADERS += include/coverhd.h
+
+all-local: $(PREINSTALL_FILES)
-PREINSTALL_FILES += $(PROJECT_RELEASE)/lib/bsp_specs.dl
+EXTRA_DIST = times
-EXTRA_DIST = bsp_specs bsp_specs.dl times
+$(PROJECT_INCLUDE)/coverhd.h: include/coverhd.h
+ $(INSTALL_DATA) $< $@
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/coverhd.h
+
+$(PROJECT_ROOT)/@RTEMS_BSP@/lib/bsp_specs.dl: bsp_specs.dl
+ $(INSTALL_DATA) $< $@
+PREINSTALL_FILES += $(PROJECT_ROOT)/@RTEMS_BSP@/lib/bsp_specs.dl
include $(top_srcdir)/../../../../automake/subdirs.am
include $(top_srcdir)/../../../../automake/local.am