summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/powerpc/gen405/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'c/src/lib/libbsp/powerpc/gen405/configure.ac')
-rw-r--r--c/src/lib/libbsp/powerpc/gen405/configure.ac26
1 files changed, 21 insertions, 5 deletions
diff --git a/c/src/lib/libbsp/powerpc/gen405/configure.ac b/c/src/lib/libbsp/powerpc/gen405/configure.ac
index 771e829801..c961996839 100644
--- a/c/src/lib/libbsp/powerpc/gen405/configure.ac
+++ b/c/src/lib/libbsp/powerpc/gen405/configure.ac
@@ -2,8 +2,9 @@ dnl Process this file with autoconf to produce a configure script.
dnl
dnl $Id$
-AC_PREREQ(2.13)
-AC_INIT(bsp_specs)
+AC_PREREQ(2.52)
+AC_INIT
+AC_CONFIG_SRCDIR([bsp_specs])
RTEMS_TOP(../../../../../..)
AC_CONFIG_AUX_DIR(../../../../../..)
@@ -23,13 +24,28 @@ RTEMS_CANONICAL_HOST
AM_CONDITIONAL(HAS_NETWORKING,test "$HAS_NETWORKING" = "yes")
+RTEMS_BSPOPTS_SET([PPC_USE_SPRG],[*],[1])
+RTEMS_BSPOPTS_HELP([PPC_USE_SPRG],
+[If defined, then the PowerPC specific code in RTEMS will use some
+ of the special purpose registers to slightly optimize interrupt
+ response time. The use of these registers can conflict with
+ other tools like debuggers.])
+
+RTEMS_BSPOPTS_SET([PPC_VECTOR_FILE_BASE],[*],[0x0100])
+RTEMS_BSPOPTS_HELP([PPC_VECTOR_FILE_BASE],
+[This defines the base address of the exception table.
+ NOTE: Vectors are actually at 0xFFF00000 but file starts at offset.])
+
AM_CONFIG_HEADER(include/bspopts.h)
RTEMS_PROJECT_ROOT
# Explicitly list all Makefiles here
-AC_OUTPUT(
-Makefile
+AC_CONFIG_FILES([Makefile
dlentry/Makefile
include/Makefile
startup/Makefile
-wrapup/Makefile)
+wrapup/Makefile])
+
+RTEMS_PPC_EXCEPTIONS([old])
+
+AC_OUTPUT