summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/powerpc/gen405/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'c/src/lib/libbsp/powerpc/gen405/Makefile.am')
-rw-r--r--c/src/lib/libbsp/powerpc/gen405/Makefile.am54
1 files changed, 51 insertions, 3 deletions
diff --git a/c/src/lib/libbsp/powerpc/gen405/Makefile.am b/c/src/lib/libbsp/powerpc/gen405/Makefile.am
index b157af5ca0..9103ddfb7e 100644
--- a/c/src/lib/libbsp/powerpc/gen405/Makefile.am
+++ b/c/src/lib/libbsp/powerpc/gen405/Makefile.am
@@ -6,24 +6,72 @@ ACLOCAL_AMFLAGS = -I ../../../../aclocal
# wrapup is the one that actually builds and installs the library
# from the individual .rel files built in other directories
-SUBDIRS = . dlentry startup @exceptions@ wrapup
+SUBDIRS = . @exceptions@ wrapup
+include $(top_srcdir)/../../../../automake/compile.am
include $(top_srcdir)/../../bsp.am
+EXTRA_PROGRAMS =
+CLEANFILES =
+noinst_DATA =
+
include_HEADERS += include/coverhd.h
-all-local: $(PREINSTALL_FILES)
+dist_project_lib_DATA += startup/linkcmds startup/linkcmds.dl
+
+EXTRA_PROGRAMS += startup.rel
+CLEANFILES += startup.rel
+startup_rel_SOURCES = startup/bspclean.c ../../shared/bsplibc.c \
+ ../../shared/bsppost.c startup/bspstart.c ../../shared/bootcard.c \
+ ../../shared/main.c ../../shared/sbrk.c startup/setvec.c \
+ ../../shared/gnatinstallhandler.c
+startup_rel_CPPFLAGS = $(AM_CPPFLAGS) $(CFLAGS_OPTIMIZE_V)
+startup_rel_LDFLAGS = $(RTEMS_RELLDFLAGS)
+
+EXTRA_PROGRAMS += startup_g.rel
+CLEANFILES += startup_g.rel
+startup_g_rel_SOURCES = $(startup_rel_SOURCES)
+startup_g_rel_CPPFLAGS = $(AM_CPPFLAGS) $(CFLAGS_DEBUG_V)
+startup_g_rel_LDFLAGS = $(RTEMS_RELLDFLAGS)
+
+noinst_DATA += startup$(LIB_VARIANT).rel
+
+EXTRA_PROGRAMS += dlentry.rel
+CLEANFILES += dlentry.rel
+dlentry_rel_SOURCES = dlentry/dlentry.S
+dlentry_rel_CPPFLAGS = $(AM_CPPFLAGS) $(CFLAGS_OPTIMIZE_V)
+dlentry_rel_LDFLAGS = $(RTEMS_RELLDFLAGS)
+
+EXTRA_PROGRAMS += dlentry_g.rel
+CLEANFILES += dlentry_g.rel
+dlentry_g_rel_SOURCES = $(dlentry_rel_SOURCES)
+dlentry_g_rel_CPPFLAGS = $(AM_CPPFLAGS) $(CFLAGS_DEBUG_V)
+dlentry_g_rel_LDFLAGS = $(RTEMS_RELLDFLAGS)
+
+noinst_DATA += dlentry$(LIB_VARIANT).rel
+
+all-local: $(PREINSTALL_FILES) $(TMPINSTALL_FILES)
EXTRA_DIST = times
PREINSTALL_DIRS =
+TMPINSTALL_FILES =
$(PROJECT_INCLUDE)/coverhd.h: include/coverhd.h $(PROJECT_INCLUDE)/$(dirstamp)
$(INSTALL_DATA) $< $(PROJECT_INCLUDE)/coverhd.h
PREINSTALL_FILES += $(PROJECT_INCLUDE)/coverhd.h
-CLEANFILES = $(PREINSTALL_FILES)
+$(PROJECT_LIB)/linkcmds: startup/linkcmds $(PROJECT_LIB)/$(dirstamp)
+ $(INSTALL_DATA) $< $(PROJECT_LIB)/linkcmds
+TMPINSTALL_FILES += $(PROJECT_LIB)/linkcmds
+
+$(PROJECT_LIB)/linkcmds.dl: startup/linkcmds.dl $(PROJECT_LIB)/$(dirstamp)
+ $(INSTALL_DATA) $< $(PROJECT_LIB)/linkcmds.dl
+TMPINSTALL_FILES += $(PROJECT_LIB)/linkcmds.dl
+
+CLEANFILES += $(PREINSTALL_FILES)
DISTCLEANFILES = $(PREINSTALL_DIRS)
+CLEANFILES += $(TMPINSTALL_FILES)
include $(top_srcdir)/../../../../automake/subdirs.am
include $(top_srcdir)/../../../../automake/local.am