summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/powerpc/eth_comm/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'c/src/lib/libbsp/powerpc/eth_comm/Makefile.am')
-rw-r--r--c/src/lib/libbsp/powerpc/eth_comm/Makefile.am26
1 files changed, 21 insertions, 5 deletions
diff --git a/c/src/lib/libbsp/powerpc/eth_comm/Makefile.am b/c/src/lib/libbsp/powerpc/eth_comm/Makefile.am
index 51d81d5a33..d8980f6b87 100644
--- a/c/src/lib/libbsp/powerpc/eth_comm/Makefile.am
+++ b/c/src/lib/libbsp/powerpc/eth_comm/Makefile.am
@@ -6,21 +6,32 @@ ACLOCAL_AMFLAGS = -I ../../../../aclocal
# wrapup is the one that actually builds and installs the library
# from the individual .rel files built in other directories
-SUBDIRS = . clock startup start canbus console irq network vectors \
- @exceptions@ wrapup
+SUBDIRS = . clock startup canbus console irq network vectors @exceptions@ \
+ wrapup
+include $(top_srcdir)/../../../../automake/compile.am
include $(top_srcdir)/../../bsp.am
+EXTRA_PROGRAMS =
+CLEANFILES =
+noinst_DATA =
+
include_bspdir = $(includedir)/bsp
include_HEADERS += include/coverhd.h include/canbus.h include/info.h
include_bsp_HEADERS = include/commproc.h include/8xx_immap.h
-all-local: $(PREINSTALL_FILES)
+EXTRA_DIST = start/start.S
+start$(LIB_VARIANT).$(OBJEXT): start/start.S
+ ${CCASCOMPILE} -DASM -o $@ -c $<
+project_lib_DATA = start$(LIB_VARIANT).$(OBJEXT)
+
+all-local: $(PREINSTALL_FILES) $(TMPINSTALL_FILES)
-EXTRA_DIST = times
+EXTRA_DIST += times
PREINSTALL_DIRS =
+TMPINSTALL_FILES =
$(PROJECT_INCLUDE)/bsp/$(dirstamp):
@$(mkdir_p) $(PROJECT_INCLUDE)/bsp
@@ -47,8 +58,13 @@ $(PROJECT_INCLUDE)/bsp/8xx_immap.h: include/8xx_immap.h $(PROJECT_INCLUDE)/bsp/$
$(INSTALL_DATA) $< $(PROJECT_INCLUDE)/bsp/8xx_immap.h
PREINSTALL_FILES += $(PROJECT_INCLUDE)/bsp/8xx_immap.h
-CLEANFILES = $(PREINSTALL_FILES)
+$(PROJECT_LIB)/start$(LIB_VARIANT).$(OBJEXT): start$(LIB_VARIANT).$(OBJEXT) $(PROJECT_LIB)/$(dirstamp)
+ $(INSTALL_DATA) $< $(PROJECT_LIB)/start$(LIB_VARIANT).$(OBJEXT)
+TMPINSTALL_FILES += $(PROJECT_LIB)/start$(LIB_VARIANT).$(OBJEXT)
+
+CLEANFILES += $(PREINSTALL_FILES)
DISTCLEANFILES = $(PREINSTALL_DIRS)
+CLEANFILES += $(TMPINSTALL_FILES)
include $(top_srcdir)/../../../../automake/subdirs.am
include $(top_srcdir)/../../../../automake/local.am