summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/mips/p4000/wrapup/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'c/src/lib/libbsp/mips/p4000/wrapup/Makefile.am')
-rw-r--r--c/src/lib/libbsp/mips/p4000/wrapup/Makefile.am23
1 files changed, 0 insertions, 23 deletions
diff --git a/c/src/lib/libbsp/mips/p4000/wrapup/Makefile.am b/c/src/lib/libbsp/mips/p4000/wrapup/Makefile.am
deleted file mode 100644
index ec5124e9c0..0000000000
--- a/c/src/lib/libbsp/mips/p4000/wrapup/Makefile.am
+++ /dev/null
@@ -1,23 +0,0 @@
-##
-## $Id$
-##
-
-BSP_FILES = startup console liblnk
-
-include $(top_srcdir)/../../../../automake/compile.am
-include $(top_srcdir)/../../../../automake/lib.am
-
-# bummer; have to use $foreach since % pattern subst rules only replace 1x
-OBJS = $(foreach piece, $(BSP_FILES), ../$(piece)/$(ARCH)/*.$(OBJEXT)) \
- ../../../../libcpu/mips/shared/cache$(LIB_VARIANT).rel \
- ../../../../libcpu/mips/shared/interrupts$(LIB_VARIANT).rel \
- ../../../../libcpu/mips/r46xx/clock$(LIB_VARIANT).rel \
- ../../../../libcpu/mips/r46xx/timer$(LIB_VARIANT).rel \
- ../../../../libcpu/mips/r46xx/vectorisrs$(LIB_VARIANT).rel
-
-$(ARCH)/libbsp.a: $(OBJS)
- $(make-library)
-
-noinst_DATA = $(ARCH)/libbsp.a
-
-include $(top_srcdir)/../../../../automake/local.am