summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/mips/p4000/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'c/src/lib/libbsp/mips/p4000/Makefile.am')
-rw-r--r--c/src/lib/libbsp/mips/p4000/Makefile.am59
1 files changed, 0 insertions, 59 deletions
diff --git a/c/src/lib/libbsp/mips/p4000/Makefile.am b/c/src/lib/libbsp/mips/p4000/Makefile.am
deleted file mode 100644
index 3a09853c9f..0000000000
--- a/c/src/lib/libbsp/mips/p4000/Makefile.am
+++ /dev/null
@@ -1,59 +0,0 @@
-##
-## $Id$
-##
-
-ACLOCAL_AMFLAGS = -I ../../../../aclocal
-
-include $(top_srcdir)/../../../../automake/compile.am
-include $(top_srcdir)/../../bsp.am
-
-dist_project_lib_DATA = bsp_specs
-
-include_HEADERS = include/bsp.h
-include_HEADERS += include/tm27.h
-
-nodist_include_HEADERS = include/bspopts.h
-DISTCLEANFILES = include/bspopts.h
-noinst_PROGRAMS =
-
-include_HEADERS += include/coverhd.h
-
-EXTRA_DIST = start/start.S
-start.$(OBJEXT): start/start.S
- $(CPPASCOMPILE) -DASM -o $@ -c $<
-project_lib_DATA = start.$(OBJEXT)
-
-dist_project_lib_DATA += startup/linkcmds
-
-noinst_PROGRAMS += startup.rel
-startup_rel_SOURCES = startup/bspclean.c ../../shared/bsplibc.c \
- ../../shared/bsppost.c startup/bspstart.c ../../shared/bootcard.c \
- ../../shared/main.c ../../shared/sbrk.c startup/setvec.c \
- startup/inittlb.c ../../shared/gnatinstallhandler.c startup/idtmem.S \
- startup/idttlb.S
-startup_rel_CPPFLAGS = $(AM_CPPFLAGS)
-startup_rel_LDFLAGS = $(RTEMS_RELLDFLAGS)
-
-noinst_PROGRAMS += console.rel
-console_rel_SOURCES = console/console.c console/led.S
-console_rel_CPPFLAGS = $(AM_CPPFLAGS)
-console_rel_LDFLAGS = $(RTEMS_RELLDFLAGS)
-
-noinst_PROGRAMS += liblnk.rel
-liblnk_rel_SOURCES = liblnk/lnklib.S
-liblnk_rel_CPPFLAGS = $(AM_CPPFLAGS)
-liblnk_rel_LDFLAGS = $(RTEMS_RELLDFLAGS)
-
-noinst_LIBRARIES = libbsp.a
-libbsp_a_SOURCES =
-libbsp_a_LIBADD = startup.rel console.rel liblnk.rel
-libbsp_a_LIBADD += ../../../libcpu/@RTEMS_CPU@/shared/cache.rel \
- ../../../libcpu/@RTEMS_CPU@/shared/interrupts.rel \
- ../../../libcpu/@RTEMS_CPU@/r46xx/clock.rel \
- ../../../libcpu/@RTEMS_CPU@/r46xx/timer.rel \
- ../../../libcpu/@RTEMS_CPU@/r46xx/vectorisrs.rel
-
-EXTRA_DIST += times
-
-include $(srcdir)/preinstall.am
-include $(top_srcdir)/../../../../automake/local.am