summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/m68k/ods68302/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'c/src/lib/libbsp/m68k/ods68302/Makefile.am')
-rw-r--r--c/src/lib/libbsp/m68k/ods68302/Makefile.am34
1 files changed, 31 insertions, 3 deletions
diff --git a/c/src/lib/libbsp/m68k/ods68302/Makefile.am b/c/src/lib/libbsp/m68k/ods68302/Makefile.am
index a04fca02c0..5c95ecd31f 100644
--- a/c/src/lib/libbsp/m68k/ods68302/Makefile.am
+++ b/c/src/lib/libbsp/m68k/ods68302/Makefile.am
@@ -5,12 +5,40 @@
ACLOCAL_AMFLAGS = -I ../../../../aclocal
# wrapup is the one that actually builds and installs the library
-# from the individual .rel files built in other directories
-SUBDIRS = . include start startup clock console timer wrapup
+# from the individual .rel files built in other directories
+SUBDIRS = . start startup clock console timer wrapup
include $(top_srcdir)/../../bsp.am
-EXTRA_DIST = bsp_specs times
+include_HEADERS += include/bare.h
+include_HEADERS += include/crc.h
+include_HEADERS += include/debugport.h
+include_HEADERS += include/m68302scc.h
+include_HEADERS += include/coverhd.h
+
+all-local: $(PREINSTALL_FILES)
+
+EXTRA_DIST = times
+
+$(PROJECT_INCLUDE)/bare.h: include/bare.h
+ $(INSTALL_DATA) $< $@
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/bare.h
+
+$(PROJECT_INCLUDE)/crc.h: include/crc.h
+ $(INSTALL_DATA) $< $@
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/crc.h
+
+$(PROJECT_INCLUDE)/debugport.h: include/debugport.h
+ $(INSTALL_DATA) $< $@
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/debugport.h
+
+$(PROJECT_INCLUDE)/m68302scc.h: include/m68302scc.h
+ $(INSTALL_DATA) $< $@
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/m68302scc.h
+
+$(PROJECT_INCLUDE)/coverhd.h: include/coverhd.h
+ $(INSTALL_DATA) $< $@
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/coverhd.h
include $(top_srcdir)/../../../../automake/subdirs.am
include $(top_srcdir)/../../../../automake/local.am