summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/m68k/mvme167/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'c/src/lib/libbsp/m68k/mvme167/Makefile.am')
-rw-r--r--c/src/lib/libbsp/m68k/mvme167/Makefile.am30
1 files changed, 27 insertions, 3 deletions
diff --git a/c/src/lib/libbsp/m68k/mvme167/Makefile.am b/c/src/lib/libbsp/m68k/mvme167/Makefile.am
index 30fa854648..16362f7b0c 100644
--- a/c/src/lib/libbsp/m68k/mvme167/Makefile.am
+++ b/c/src/lib/libbsp/m68k/mvme167/Makefile.am
@@ -5,13 +5,37 @@
ACLOCAL_AMFLAGS = -I ../../../../aclocal
# wrapup is the one that actually builds and installs the library
-# from the individual .rel files built in other directories
+# from the individual .rel files built in other directories
-SUBDIRS = . include start startup clock console fatal timer network wrapup
+SUBDIRS = . start startup clock console fatal timer network wrapup
include $(top_srcdir)/../../bsp.am
-EXTRA_DIST = bsp_specs times
+include_HEADERS += include/coverhd.h
+include_HEADERS += include/page_table.h
+include_HEADERS += include/fatal.h
+
+nodist_include_HEADERS += $(top_srcdir)/../shared/mvme/mvme16x_hw.h
+
+all: $(PREINSTALL_FILES)
+
+EXTRA_DIST = times
+
+$(PROJECT_INCLUDE)/coverhd.h: include/coverhd.h
+ $(INSTALL_DATA) $< $@
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/coverhd.h
+
+$(PROJECT_INCLUDE)/page_table.h: include/page_table.h
+ $(INSTALL_DATA) $< $@
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/page_table.h
+
+$(PROJECT_INCLUDE)/fatal.h: include/fatal.h
+ $(INSTALL_DATA) $< $@
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/fatal.h
+
+$(PROJECT_INCLUDE)/mvme16x_hw.h: $(top_srcdir)/../shared/mvme/mvme16x_hw.h
+ $(INSTALL_DATA) $< $@
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/mvme16x_hw.h
include $(top_srcdir)/../../../../automake/subdirs.am
include $(top_srcdir)/../../../../automake/local.am