summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/i960/rxgen960/wrapup/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'c/src/lib/libbsp/i960/rxgen960/wrapup/Makefile.am')
-rw-r--r--c/src/lib/libbsp/i960/rxgen960/wrapup/Makefile.am13
1 files changed, 2 insertions, 11 deletions
diff --git a/c/src/lib/libbsp/i960/rxgen960/wrapup/Makefile.am b/c/src/lib/libbsp/i960/rxgen960/wrapup/Makefile.am
index 72693524d5..19e6003286 100644
--- a/c/src/lib/libbsp/i960/rxgen960/wrapup/Makefile.am
+++ b/c/src/lib/libbsp/i960/rxgen960/wrapup/Makefile.am
@@ -8,20 +8,11 @@ include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
include $(top_srcdir)/../../../../../../automake/compile.am
include $(top_srcdir)/../../../../../../automake/lib.am
-if HAS_MP
-GENERIC_MP_REL_PIECES = shmdr
-endif
-GENERIC_PIECES += $(GENERIC_MP_REL_PIECES)
-
-if HAS_MP
-BSP_MP_O_PIECES = shmsupp
-endif
-BSP_PIECES = startup clock console timer $(BSP_MP_O_PIECES)
+BSP_PIECES = startup clock console timer
# bummer; have to use $foreach since % pattern subst rules only replace 1x
OBJS = $(foreach piece, $(BSP_PIECES), $(wildcard ../$(piece)/$(ARCH)/*.o)) \
- $(wildcard ../../../../libcpu/$(RTEMS_CPU)/$(RTEMS_CPU_MODEL)/$(ARCH)/*.o) \
- $(foreach piece, $(GENERIC_PIECES), ../../../$(piece)/$(ARCH)/$(piece).rel)
+ $(wildcard ../../../../libcpu/$(RTEMS_CPU)/$(RTEMS_CPU_MODEL)/$(ARCH)/*.o)
LIB = $(ARCH)/libbsp.a
#