summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/i386/pc386/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'c/src/lib/libbsp/i386/pc386/Makefile.am')
-rw-r--r--c/src/lib/libbsp/i386/pc386/Makefile.am33
1 files changed, 29 insertions, 4 deletions
diff --git a/c/src/lib/libbsp/i386/pc386/Makefile.am b/c/src/lib/libbsp/i386/pc386/Makefile.am
index 2784052e50..b9518547a7 100644
--- a/c/src/lib/libbsp/i386/pc386/Makefile.am
+++ b/c/src/lib/libbsp/i386/pc386/Makefile.am
@@ -5,9 +5,9 @@
ACLOCAL_AMFLAGS = -I ../../../../aclocal
# wrapup is the one that actually builds and installs the library
-# from the individual .rel files built in other directories
-SUBDIRS = . include tools start startup clock console timer ne2000 wd8003 \
- 3c509 ide wrapup
+# from the individual .rel files built in other directories
+SUBDIRS = . tools start startup clock console timer ne2000 wd8003 3c509 ide \
+ wrapup
include $(top_srcdir)/../../bsp.am
@@ -16,7 +16,32 @@ $(PROJECT_RELEASE)/BootImgs:
TMPINSTALL_FILES = $(PROJECT_RELEASE)/BootImgs
-EXTRA_DIST = HOWTO README.dec21140 STATUS bsp_specs times_i486dx times_p5
+# This driver needs to be reworked for the BSD stack.
+# We only install wd80x3.h if HAS_NETWORKING was defined
+if HAS_NETWORKING
+include_HEADERS += include/wd80x3.h
+endif
+
+include_HEADERS += include/crt.h
+nodist_include_HEADERS += $(top_srcdir)/../../shared/include/coverhd.h
+
+all-local: $(PREINSTALL_FILES)
+
+EXTRA_DIST = HOWTO README.dec21140 STATUS times_i486dx times_p5
+
+if HAS_NETWORKING
+$(PROJECT_INCLUDE)/wd80x3.h: include/wd80x3.h
+ $(INSTALL_DATA) $< $@
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/wd80x3.h
+endif
+
+$(PROJECT_INCLUDE)/crt.h: include/crt.h
+ $(INSTALL_DATA) $< $@
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/crt.h
+
+$(PROJECT_INCLUDE)/coverhd.h: $(top_srcdir)/../../shared/include/coverhd.h
+ $(INSTALL_DATA) $< $@
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/coverhd.h
include $(top_srcdir)/../../../../automake/subdirs.am
include $(top_srcdir)/../../../../automake/local.am