summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/h8300/h8sim/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'c/src/lib/libbsp/h8300/h8sim/Makefile.am')
-rw-r--r--c/src/lib/libbsp/h8300/h8sim/Makefile.am16
1 files changed, 9 insertions, 7 deletions
diff --git a/c/src/lib/libbsp/h8300/h8sim/Makefile.am b/c/src/lib/libbsp/h8300/h8sim/Makefile.am
index fa62b6409d..d511f30516 100644
--- a/c/src/lib/libbsp/h8300/h8sim/Makefile.am
+++ b/c/src/lib/libbsp/h8300/h8sim/Makefile.am
@@ -28,20 +28,22 @@ project_lib_DATA = start.$(OBJEXT)
dist_project_lib_DATA += startup/linkcmds
noinst_LIBRARIES = libbsp.a
+libbsp_a_SOURCES =
-startup_SOURCES = ../../shared/bspclean.c ../../shared/bsplibc.c \
+# startup
+libbsp_a_SOURCES += ../../shared/bspclean.c ../../shared/bsplibc.c \
../../shared/bsppredriverhook.c ../../shared/bsppretaskinghook.c \
../../shared/bspgetworkarea.c ../../shared/bsppost.c \
../../shared/bspstart.c startup/h8bdinstallirq.c \
../../shared/bootcard.c ../../shared/sbrk.c \
../../shared/gnatinstallhandler.c startup/__main.c
-clock_SOURCES = ../../shared/clock_driver_simidle.c
-console_SOURCES = ../../shared/console-polled.c console/console-io.c \
+# clock
+libbsp_a_SOURCES += ../../shared/clock_driver_simidle.c
+# console
+libbsp_a_SOURCES += ../../shared/console-polled.c console/console-io.c \
console/syscalls.S
-timer_SOURCES = ../../shared/timerstub.c
-
-libbsp_a_SOURCES = $(startup_SOURCES) $(clock_SOURCES) $(console_SOURCES) \
- $(timer_SOURCES)
+# timer
+libbsp_a_SOURCES += ../../shared/timerstub.c
EXTRA_DIST += times