summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/c4x/c4xsim/wrapup/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'c/src/lib/libbsp/c4x/c4xsim/wrapup/Makefile.am')
-rw-r--r--c/src/lib/libbsp/c4x/c4xsim/wrapup/Makefile.am9
1 files changed, 2 insertions, 7 deletions
diff --git a/c/src/lib/libbsp/c4x/c4xsim/wrapup/Makefile.am b/c/src/lib/libbsp/c4x/c4xsim/wrapup/Makefile.am
index 96d876e004..c660825bdf 100644
--- a/c/src/lib/libbsp/c4x/c4xsim/wrapup/Makefile.am
+++ b/c/src/lib/libbsp/c4x/c4xsim/wrapup/Makefile.am
@@ -10,18 +10,13 @@ CPU_PIECES =
OBJS = $(foreach piece, $(BSP_PIECES), ../$(piece)/$(ARCH)/*.$(OBJEXT)) \
$(foreach piece, $(CPU_PIECES), \
../../../../libcpu/$(RTEMS_CPU)/$(piece)/$(ARCH)/$(piece).rel)
-LIB = $(ARCH)/libbsp.a
include $(top_srcdir)/../../../../automake/compile.am
include $(top_srcdir)/../../../../automake/lib.am
-#
-# (OPTIONAL) Add local stuff here using +=
-#
-
-$(LIB): $(OBJS)
+$(ARCH)/libbsp.a: $(OBJS)
$(make-library)
-all-local: $(LIB)
+noinst_DATA = $(ARCH)/libbsp.a
include $(top_srcdir)/../../../../automake/local.am