summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/arm/vegaplus/startup/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'c/src/lib/libbsp/arm/vegaplus/startup/Makefile.am')
-rw-r--r--c/src/lib/libbsp/arm/vegaplus/startup/Makefile.am24
1 files changed, 12 insertions, 12 deletions
diff --git a/c/src/lib/libbsp/arm/vegaplus/startup/Makefile.am b/c/src/lib/libbsp/arm/vegaplus/startup/Makefile.am
index ef64b64dad..764e703b76 100644
--- a/c/src/lib/libbsp/arm/vegaplus/startup/Makefile.am
+++ b/c/src/lib/libbsp/arm/vegaplus/startup/Makefile.am
@@ -1,40 +1,40 @@
-##
+##
## $Id$
-##
+##
AUTOMAKE_OPTIONS = foreign 1.4
VPATH = @srcdir@:@srcdir@/../../../shared
-C_FILES = bsplibc.c bsppost.c bspstart.c exit.c bootcard.c main.c sbrk.c gnatinstallhandler.c
-C_O_FILES = $(C_FILES:%.c=$(ARCH)/%.o)
+PGM = $(ARCH)/startup.rel
-S_FILES =
-S_O_FILES = $(S_FILES:%.S=$(ARCH)/%.o)
+C_FILES = bsplibc.c bsppost.c bspstart.c exit.c bootcard.c main.c sbrk.c \
+ gnatinstallhandler.c
+C_O_FILES = $(C_FILES:%.c=$(ARCH)/%.o)
-startup_rel_OBJECTS = $(C_O_FILES) $(S_O_FILES)
+OBJS = $(C_O_FILES)
include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
+include $(top_srcdir)/../../../../../../automake/compile.am
include $(top_srcdir)/../../../../../../automake/lib.am
#
# (OPTIONAL) Add local stuff here using +=
#
-
-$(PGM): $(startup_rel_OBJECTS)
+$(PGM): $(OBJS)
$(make-rel)
$(PROJECT_RELEASE)/lib/linkcmds: linkcmds
$(INSTALL_DATA) $< $@
+# the .rel file built here will be put into libbsp.a by ../wrapup/Makefile
TMPINSTALL_FILES += $(PROJECT_RELEASE)/lib/linkcmds
-all: $(ARCH) $(startup_rel_OBJECTS) $(PGM) $(TMPINSTALL_FILES)
+all-local: $(ARCH) $(OBJS) $(PGM) $(TMPINSTALL_FILES)
.PRECIOUS: $(PGM)
-EXTRA_DIST = linkcmds
+EXTRA_DIST = bspstart.c exit.c linkcmds
include $(top_srcdir)/../../../../../../automake/local.am
-