summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/arm/vegaplus/console/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'c/src/lib/libbsp/arm/vegaplus/console/Makefile.am')
-rw-r--r--c/src/lib/libbsp/arm/vegaplus/console/Makefile.am17
1 files changed, 11 insertions, 6 deletions
diff --git a/c/src/lib/libbsp/arm/vegaplus/console/Makefile.am b/c/src/lib/libbsp/arm/vegaplus/console/Makefile.am
index 668e7c05b5..b87e7b0332 100644
--- a/c/src/lib/libbsp/arm/vegaplus/console/Makefile.am
+++ b/c/src/lib/libbsp/arm/vegaplus/console/Makefile.am
@@ -8,25 +8,30 @@ VPATH = @srcdir@/../../shared/comm:@srcdir@/../../shared/io
PGM = $(ARCH)/console.rel
-C_FILES = uart.c console.c printk.c
+C_FILES = uart.c console.c
C_O_FILES = $(C_FILES:%.c=$(ARCH)/%.o)
-H_FILES = uart.h bspio.h
-
-console_rel_OBJECTS = $(C_FILES:%.c=$(ARCH)/%.o)
+OBJS = $(C_O_FILES)
include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
+include $(top_srcdir)/../../../../../../automake/compile.am
include $(top_srcdir)/../../../../../../automake/lib.am
#
# (OPTIONAL) Add local stuff here using +=
#
-$(PGM): $(console_rel_OBJECTS)
+AM_CPPFLAGS += -I $(srcdir)/../irq
+
+$(PGM): $(OBJS)
$(make-rel)
-all: $(ARCH) $(console_rel_OBJECTS) $(PGM)
+# the .rel file built here will be put into libbsp.a by ../wrapup/Makefile
+
+all-local: $(ARCH) $(OBJS) $(PGM)
.PRECIOUS: $(PGM)
+EXTRA_DIST = console.c
+
include $(top_srcdir)/../../../../../../automake/local.am