summaryrefslogtreecommitdiffstats
path: root/c/src/exec/score/inline/rtems/score/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'c/src/exec/score/inline/rtems/score/Makefile.am')
-rw-r--r--c/src/exec/score/inline/rtems/score/Makefile.am8
1 files changed, 6 insertions, 2 deletions
diff --git a/c/src/exec/score/inline/rtems/score/Makefile.am b/c/src/exec/score/inline/rtems/score/Makefile.am
index 6b6083f625..ccedd88c6d 100644
--- a/c/src/exec/score/inline/rtems/score/Makefile.am
+++ b/c/src/exec/score/inline/rtems/score/Makefile.am
@@ -4,6 +4,8 @@
AUTOMAKE_OPTIONS = foreign 1.4
+include_rtems_scoredir = $(includedir)/rtems/score
+
## We only build multiprocessing related files if HAS_MP was defined
MP_I_FILES = mppkt.inl objectmp.inl threadmp.inl
@@ -18,11 +20,11 @@ else
I_FILES = $(STD_I_FILES)
endif
-noinst_HEADERS = $(STD_I_FILES) $(MP_I_FILES)
+include_rtems_score_HEADERS = $(I_FILES)
if INLINE
PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/score \
- $(I_FILES:%=$(PROJECT_INCLUDE)/rtems/score/%)
+ $(include_rtems_score_HEADERS:%=$(PROJECT_INCLUDE)/rtems/score/%)
$(PROJECT_INCLUDE)/rtems/score:
@$(mkinstalldirs) $@
@@ -32,4 +34,6 @@ endif
all-local: $(PREINSTALL_FILES)
+EXTRA_DIST = $(STD_I_FILES) $(MP_I_FILES)
+
include $(top_srcdir)/../../../automake/local.am