summaryrefslogtreecommitdiffstats
path: root/c/src/exec/score/cpu/unix/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'c/src/exec/score/cpu/unix/Makefile.am')
-rw-r--r--c/src/exec/score/cpu/unix/Makefile.am26
1 files changed, 22 insertions, 4 deletions
diff --git a/c/src/exec/score/cpu/unix/Makefile.am b/c/src/exec/score/cpu/unix/Makefile.am
index 53d1b38c98..3437921396 100644
--- a/c/src/exec/score/cpu/unix/Makefile.am
+++ b/c/src/exec/score/cpu/unix/Makefile.am
@@ -2,17 +2,36 @@
## $Id$
##
-AUTOMAKE_OPTIONS = foreign 1.4
+AUTOMAKE_OPTIONS = foreign 1.5
ACLOCAL_AMFLAGS = -I ../../../../../../aclocal
include $(top_srcdir)/../../../../../../automake/multilib.am
include $(top_srcdir)/../../../../../../automake/compile.am
include $(top_srcdir)/../../../../../../automake/lib.am
-SUBDIRS = rtems
-
AM_CPPFLAGS += -DCPU_SYNC_IO $(LIBC_DEFINES)
+$(PROJECT_INCLUDE)/%.h: %.h
+ $(INSTALL_DATA) $< $@
+
+$(PROJECT_INCLUDE):
+ $(mkinstalldirs) $@
+
+$(PROJECT_INCLUDE)/rtems:
+ $(mkinstalldirs) $@
+
+$(PROJECT_INCLUDE)/rtems/score:
+ $(mkinstalldirs) $@
+
+include_rtems_scoredir = $(includedir)/rtems/score
+include_rtems_score_HEADERS = \
+ rtems/score/unixtypes.h \
+ rtems/score/cpu.h \
+ rtems/score/unix.h \
+ rtems/score/unixsize.h
+PREINSTALL_FILES = $(PROJECT_INCLUDE)/rtems/score \
+ $(include_rtems_score_HEADERS:%.h=$(PROJECT_INCLUDE)/%.h)
+
C_FILES = cpu.c
C_O_FILES = $(C_FILES:%.c=$(ARCH)/%.o)
@@ -29,5 +48,4 @@ all-local: $(ARCH) $(rtems_cpu_rel_OBJECTS) $(REL)
EXTRA_DIST = cpu.c
-include $(top_srcdir)/../../../../../../automake/subdirs.am
include $(top_srcdir)/../../../../../../automake/local.am