summaryrefslogtreecommitdiffstats
path: root/c/src/exec/score/cpu/powerpc/rtems/score/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'c/src/exec/score/cpu/powerpc/rtems/score/Makefile.am')
-rw-r--r--c/src/exec/score/cpu/powerpc/rtems/score/Makefile.am25
1 files changed, 25 insertions, 0 deletions
diff --git a/c/src/exec/score/cpu/powerpc/rtems/score/Makefile.am b/c/src/exec/score/cpu/powerpc/rtems/score/Makefile.am
new file mode 100644
index 0000000000..6c10af1ba2
--- /dev/null
+++ b/c/src/exec/score/cpu/powerpc/rtems/score/Makefile.am
@@ -0,0 +1,25 @@
+##
+## $Id$
+##
+
+AUTOMAKE_OPTIONS = foreign 1.5
+
+include_rtems_scoredir = $(includedir)/rtems/score
+include_rtems_score_HEADERS = ppc.h ppctypes.h
+
+#
+# (OPTIONAL) Add local stuff here using +=
+#
+
+PREINSTALL_FILES = $(PROJECT_INCLUDE)/rtems/score \
+ $(include_rtems_score_HEADERS:%.h=$(PROJECT_INCLUDE)/rtems/score/%.h)
+
+$(PROJECT_INCLUDE)/rtems/score:
+ $(mkinstalldirs) $@
+
+$(PROJECT_INCLUDE)/rtems/score/%.h: %.h
+ $(INSTALL_DATA) $< $@
+
+all-local: $(PREINSTALL_FILES)
+
+include $(top_srcdir)/../../../../../../automake/local.am