summaryrefslogtreecommitdiffstats
path: root/c/src/exec/rtems/macros/rtems/rtems/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'c/src/exec/rtems/macros/rtems/rtems/Makefile.am')
-rw-r--r--c/src/exec/rtems/macros/rtems/rtems/Makefile.am9
1 files changed, 6 insertions, 3 deletions
diff --git a/c/src/exec/rtems/macros/rtems/rtems/Makefile.am b/c/src/exec/rtems/macros/rtems/rtems/Makefile.am
index dacf3011fe..e29786d591 100644
--- a/c/src/exec/rtems/macros/rtems/rtems/Makefile.am
+++ b/c/src/exec/rtems/macros/rtems/rtems/Makefile.am
@@ -4,16 +4,17 @@
AUTOMAKE_OPTIONS = foreign 1.4
+include_rtems_rtemsdir = $(includedir)/rtems/rtems
+
I_FILES = asr.inl attr.inl dpmem.inl event.inl eventset.inl message.inl \
modes.inl options.inl part.inl ratemon.inl region.inl sem.inl status.inl \
support.inl tasks.inl timer.inl
-noinst_HEADERS = $(I_FILES)
-
if MACROS
+include_rtems_rtems_HEADERS = $(I_FILES)
PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/rtems \
- $(I_FILES:%=$(PROJECT_INCLUDE)/rtems/rtems/%)
+ $(include_rtems_rtems_HEADERS:%=$(PROJECT_INCLUDE)/rtems/rtems/%)
$(PROJECT_INCLUDE)/rtems/rtems:
@$(mkinstalldirs) $@
@@ -23,4 +24,6 @@ endif
all-local: $(PREINSTALL_FILES)
+EXTRA_DIST = $(I_FILES)
+
include $(top_srcdir)/../../../automake/local.am