summaryrefslogtreecommitdiffstats
path: root/c/src/exec/rtems/inline/rtems/rtems/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'c/src/exec/rtems/inline/rtems/rtems/Makefile.am')
-rw-r--r--c/src/exec/rtems/inline/rtems/rtems/Makefile.am10
1 files changed, 7 insertions, 3 deletions
diff --git a/c/src/exec/rtems/inline/rtems/rtems/Makefile.am b/c/src/exec/rtems/inline/rtems/rtems/Makefile.am
index b8b787a40e..b0baa5694c 100644
--- a/c/src/exec/rtems/inline/rtems/rtems/Makefile.am
+++ b/c/src/exec/rtems/inline/rtems/rtems/Makefile.am
@@ -4,15 +4,17 @@
AUTOMAKE_OPTIONS = foreign 1.4
-if INLINE
+include_rtems_rtemsdir = $(includedir)/rtems/rtems
+
I_FILES = asr.inl attr.inl dpmem.inl event.inl eventset.inl message.inl \
modes.inl options.inl part.inl ratemon.inl region.inl sem.inl status.inl \
support.inl tasks.inl timer.inl
-noinst_HEADERS = $(I_FILES)
+if INLINE
+include_rtems_rtems_HEADERS = $(I_FILES)
PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/rtems \
- $(noinst_HEADERS:%=$(PROJECT_INCLUDE)/rtems/rtems/%)
+ $(include_rtems_rtems_HEADERS:%=$(PROJECT_INCLUDE)/rtems/rtems/%)
$(PROJECT_INCLUDE)/rtems/rtems:
@$(mkinstalldirs) $@
@@ -22,4 +24,6 @@ endif
all-local: $(PREINSTALL_FILES)
+EXTRA_DIST = $(I_FILES)
+
include $(top_srcdir)/../../../automake/local.am