summaryrefslogtreecommitdiffstats
path: root/c/src/exec/libnetworking/wrapup/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'c/src/exec/libnetworking/wrapup/Makefile.am')
-rw-r--r--c/src/exec/libnetworking/wrapup/Makefile.am15
1 files changed, 5 insertions, 10 deletions
diff --git a/c/src/exec/libnetworking/wrapup/Makefile.am b/c/src/exec/libnetworking/wrapup/Makefile.am
index ff8817f1d7..650d101bbf 100644
--- a/c/src/exec/libnetworking/wrapup/Makefile.am
+++ b/c/src/exec/libnetworking/wrapup/Makefile.am
@@ -3,18 +3,13 @@
##
-if HAS_POSIX
-POSIX_PIECES = rtems_webserver
-endif
-
-NET_O_PIECES = kern lib libc net netinet nfs rtems rtems_servers \
- rtems_telnetd pppd $(POSIX_PIECES)
+NET_O_PIECES = kern lib libc net netinet nfs rtems
OBJS = $(foreach piece, $(NET_O_PIECES), ../$(piece)/$(ARCH)/*.o)
LIB = $(ARCH)/libnetworking.a
-include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
-include $(top_srcdir)/../../../automake/compile.am
-include $(top_srcdir)/../../../automake/lib.am
+include $(top_srcdir)/../../../../automake/multilib.am
+include $(top_srcdir)/../../../../automake/compile.am
+include $(top_srcdir)/../../../../automake/lib.am
#
# (OPTIONAL) Add local stuff here using +=
@@ -32,4 +27,4 @@ all-local: $(ARCH) $(OBJS) $(LIB) $(TMPINSTALL_FILES)
.PRECIOUS: $(LIB)
-include $(top_srcdir)/../../../automake/local.am
+include $(top_srcdir)/../../../../automake/local.am