summaryrefslogtreecommitdiffstats
path: root/c/src/exec/libnetworking/nfs/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'c/src/exec/libnetworking/nfs/Makefile.am')
-rw-r--r--c/src/exec/libnetworking/nfs/Makefile.am7
1 files changed, 4 insertions, 3 deletions
diff --git a/c/src/exec/libnetworking/nfs/Makefile.am b/c/src/exec/libnetworking/nfs/Makefile.am
index 9a8b43e31a..2d9b4dcf4c 100644
--- a/c/src/exec/libnetworking/nfs/Makefile.am
+++ b/c/src/exec/libnetworking/nfs/Makefile.am
@@ -13,6 +13,7 @@ C_O_FILES = $(C_FILES:%.c=$(ARCH)/%.o)
OBJS = $(C_O_FILES)
include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
+include $(top_srcdir)/../../../automake/compile.am
include $(top_srcdir)/../../../automake/lib.am
#
@@ -29,13 +30,14 @@ all-local: $(PREINSTALL_FILES) $(ARCH) $(OBJS) $(LIB)
.PRECIOUS: $(LIB)
-EXTRA_DIST = bootp_subr.c
+EXTRA_DIST = bootp_subr.c
H_FILES = krpc.h nfs.h nfsdiskless.h nfsproto.h rpcv2.h xdr_subs.h
noinst_HEADERS = $(H_FILES)
-PREINSTALL_FILES += $(PROJECT_INCLUDE)/nfs $(H_FILES:%=$(PROJECT_INCLUDE)/nfs/%)
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/nfs \
+ $(H_FILES:%=$(PROJECT_INCLUDE)/nfs/%)
$(PROJECT_INCLUDE)/nfs:
@$(mkinstalldirs) $@
@@ -43,5 +45,4 @@ $(PROJECT_INCLUDE)/nfs:
$(PROJECT_INCLUDE)/nfs/%.h: %.h
$(INSTALL_DATA) $< $@
-
include $(top_srcdir)/../../../automake/local.am