summaryrefslogtreecommitdiffstats
path: root/c/src/exec/libblock/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'c/src/exec/libblock/Makefile.am')
-rw-r--r--c/src/exec/libblock/Makefile.am20
1 files changed, 19 insertions, 1 deletions
diff --git a/c/src/exec/libblock/Makefile.am b/c/src/exec/libblock/Makefile.am
index 1f68c561e5..85a2b6af6a 100644
--- a/c/src/exec/libblock/Makefile.am
+++ b/c/src/exec/libblock/Makefile.am
@@ -4,7 +4,25 @@
ACLOCAL_AMFLAGS = -I ../aclocal
-SUBDIRS = include src
+SUBDIRS = src
+
+include_rtemsdir = $(includedir)/rtems
+
+$(PROJECT_INCLUDE)/%.h: include/%.h
+ $(INSTALL_DATA) $< $@
+
+$(PROJECT_INCLUDE)/rtems:
+ @$(mkinstalldirs) $@
+
+include_rtems_HEADERS = \
+ include/rtems/bdbuf.h include/rtems/blkdev.h \
+ include/rtems/diskdevs.h include/rtems/ramdisk.h
+
+PREINSTALL_FILES = $(PROJECT_INCLUDE)/rtems \
+ $(include_rtems_HEADERS:include/%=$(PROJECT_INCLUDE)/%)
+
+all-local: $(PREINSTALL_FILES)
+
EXTRA_DIST = README