summaryrefslogtreecommitdiffstats
path: root/c/src/exec/libblock/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2002-06-18 12:36:40 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2002-06-18 12:36:40 +0000
commit9909f34c49f79632b622eea7a35c08b20df42650 (patch)
treee48386ca0795acbbd5ec7ea665d2ce1f631d8e29 /c/src/exec/libblock/Makefile.am
parent2002-06-18 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-9909f34c49f79632b622eea7a35c08b20df42650.tar.bz2
2002-06-18 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* Makefile.am: Merge-in include/Makefile.am. * include/Makefile.am: Remove. * configure.ac: Reflect changes above.
Diffstat (limited to 'c/src/exec/libblock/Makefile.am')
-rw-r--r--c/src/exec/libblock/Makefile.am20
1 files changed, 19 insertions, 1 deletions
diff --git a/c/src/exec/libblock/Makefile.am b/c/src/exec/libblock/Makefile.am
index 1f68c561e5..85a2b6af6a 100644
--- a/c/src/exec/libblock/Makefile.am
+++ b/c/src/exec/libblock/Makefile.am
@@ -4,7 +4,25 @@
ACLOCAL_AMFLAGS = -I ../aclocal
-SUBDIRS = include src
+SUBDIRS = src
+
+include_rtemsdir = $(includedir)/rtems
+
+$(PROJECT_INCLUDE)/%.h: include/%.h
+ $(INSTALL_DATA) $< $@
+
+$(PROJECT_INCLUDE)/rtems:
+ @$(mkinstalldirs) $@
+
+include_rtems_HEADERS = \
+ include/rtems/bdbuf.h include/rtems/blkdev.h \
+ include/rtems/diskdevs.h include/rtems/ramdisk.h
+
+PREINSTALL_FILES = $(PROJECT_INCLUDE)/rtems \
+ $(include_rtems_HEADERS:include/%=$(PROJECT_INCLUDE)/%)
+
+all-local: $(PREINSTALL_FILES)
+
EXTRA_DIST = README