summaryrefslogtreecommitdiffstats
path: root/c/src/exec/itron/macros/rtems/itron/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'c/src/exec/itron/macros/rtems/itron/Makefile.am')
-rw-r--r--c/src/exec/itron/macros/rtems/itron/Makefile.am10
1 files changed, 7 insertions, 3 deletions
diff --git a/c/src/exec/itron/macros/rtems/itron/Makefile.am b/c/src/exec/itron/macros/rtems/itron/Makefile.am
index 45bee17d6f..3e62ebeac7 100644
--- a/c/src/exec/itron/macros/rtems/itron/Makefile.am
+++ b/c/src/exec/itron/macros/rtems/itron/Makefile.am
@@ -4,15 +4,17 @@
AUTOMAKE_OPTIONS = foreign 1.4
-if MACROS
+include_rtems_itrondir = $(includedir)/rtems/itron
+
I_FILES = eventflags.inl fmempool.inl intr.inl mbox.inl msgbuffer.inl \
network.inl port.inl semaphore.inl sysmgmt.inl task.inl time.inl \
vmempool.inl
-noinst_HEADERS = $(I_FILES)
+if MACROS
+include_rtems_itron_HEADERS = $(I_FILES)
PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/itron \
- $(I_FILES:%=$(PROJECT_INCLUDE)/rtems/itron/%)
+ $(include_rtems_itron_HEADERS:%=$(PROJECT_INCLUDE)/rtems/itron/%)
$(PROJECT_INCLUDE)/rtems/itron:
@$(mkinstalldirs) $@
@@ -22,4 +24,6 @@ endif
all-local: $(PREINSTALL_FILES)
+EXTRA_DIST = $(I_FILES)
+
include $(top_srcdir)/../../../../automake/local.am