summaryrefslogtreecommitdiffstats
path: root/c/src/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'c/src/configure.ac')
-rw-r--r--c/src/configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/c/src/configure.ac b/c/src/configure.ac
index 20f454ac27..58b0afad59 100644
--- a/c/src/configure.ac
+++ b/c/src/configure.ac
@@ -110,6 +110,15 @@ AS_IF([test "$RTEMS_HAS_CPLUSPLUS" = "yes"],[
])
BSP_SUBDIRS="$BSP_SUBDIRS wrapup"
+
+AC_ARG_ENABLE([ada],[enable building ada bindings])
+AS_IF([test x"$enable_ada" = x"yes"],[
+ AS_IF([test -d ${srcdir}/ada-tests],[
+ AC_CONFIG_SUBDIRS([ada-tests])
+ BSP_SUBDIRS="$BSP_SUBDIRS ada-tests"
+ ])
+])
+
AC_CONFIG_SUBDIRS([tests])
BSP_SUBDIRS="$BSP_SUBDIRS tests"