summaryrefslogtreecommitdiffstats
path: root/c/src/configure.ac
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2002-08-28 14:16:18 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2002-08-28 14:16:18 +0000
commita456af96f29b45d860dd6530ae42ed807287573b (patch)
tree15ecac41faa97ab20d1464a14fa712cb3564f2fa /c/src/configure.ac
parent2002-08-27 Joel Sherrill <joel@OARcorp.com> (diff)
downloadrtems-a456af96f29b45d860dd6530ae42ed807287573b.tar.bz2
2002-08-28 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* configure.ac: Add ada-tests.
Diffstat (limited to 'c/src/configure.ac')
-rw-r--r--c/src/configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/c/src/configure.ac b/c/src/configure.ac
index 20f454ac27..58b0afad59 100644
--- a/c/src/configure.ac
+++ b/c/src/configure.ac
@@ -110,6 +110,15 @@ AS_IF([test "$RTEMS_HAS_CPLUSPLUS" = "yes"],[
])
BSP_SUBDIRS="$BSP_SUBDIRS wrapup"
+
+AC_ARG_ENABLE([ada],[enable building ada bindings])
+AS_IF([test x"$enable_ada" = x"yes"],[
+ AS_IF([test -d ${srcdir}/ada-tests],[
+ AC_CONFIG_SUBDIRS([ada-tests])
+ BSP_SUBDIRS="$BSP_SUBDIRS ada-tests"
+ ])
+])
+
AC_CONFIG_SUBDIRS([tests])
BSP_SUBDIRS="$BSP_SUBDIRS tests"