summaryrefslogtreecommitdiffstats
path: root/c/src/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'c/src/configure.ac')
-rw-r--r--c/src/configure.ac11
1 files changed, 10 insertions, 1 deletions
diff --git a/c/src/configure.ac b/c/src/configure.ac
index 6613eaf612..6eecc707b3 100644
--- a/c/src/configure.ac
+++ b/c/src/configure.ac
@@ -20,7 +20,16 @@ AM_MAINTAINER_MODE
RTEMS_ENABLE_MULTILIB
RTEMS_ENABLE_MULTIPROCESSING
RTEMS_ENV_RTEMSBSP
-RTEMS_CHECK_CPU
+
+# Is this a supported CPU?
+AC_MSG_CHECKING([if cpu $RTEMS_CPU is supported])
+# FIXME: Temporary hack
+if test -d "$srcdir/lib/libbsp/$RTEMS_CPU"; then
+ AC_MSG_RESULT(yes)
+else
+ AC_MSG_ERROR(no)
+fi
+
RTEMS_CHECK_CUSTOM_BSP(RTEMS_BSP)
RTEMS_CHECK_NETWORKING(RTEMS_BSP)