summaryrefslogtreecommitdiffstats
path: root/c/src/ada/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'c/src/ada/Makefile.am')
-rw-r--r--c/src/ada/Makefile.am8
1 files changed, 5 insertions, 3 deletions
diff --git a/c/src/ada/Makefile.am b/c/src/ada/Makefile.am
index 17f4223a75..3f4977d13d 100644
--- a/c/src/ada/Makefile.am
+++ b/c/src/ada/Makefile.am
@@ -2,9 +2,8 @@
# $Id$
#
-include_adadir = $(includedir)/adainclude
-
if RTEMS_ADA
+include_adadir = $(includedir)/adainclude
include_ada_HEADERS = rtems.adb rtems.ads
include_ada_HEADERS += rtems-multiprocessing.adb rtems-multiprocessing.ads
endif
@@ -13,11 +12,12 @@ all-local: $(PREINSTALL_FILES)
PREINSTALL_FILES =
+if RTEMS_ADA
$(PROJECT_INCLUDE)/adainclude/$(dirstamp):
@$(mkdir_p) $(PROJECT_INCLUDE)/adainclude
@: > $(PROJECT_INCLUDE)/adainclude/$(dirstamp)
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/adainclude/$(dirstamp)
-if RTEMS_ADA
$(PROJECT_INCLUDE)/adainclude/rtems.adb: rtems.adb $(PROJECT_INCLUDE)/adainclude/$(dirstamp)
$(INSTALL_DATA) $< $(PROJECT_INCLUDE)/adainclude/rtems.adb
PREINSTALL_FILES += $(PROJECT_INCLUDE)/adainclude/rtems.adb
@@ -35,4 +35,6 @@ $(PROJECT_INCLUDE)/adainclude/rtems-multiprocessing.ads: rtems-multiprocessing.a
PREINSTALL_FILES += $(PROJECT_INCLUDE)/adainclude/rtems-multiprocessing.ads
endif
+CLEANFILES = $(PREINSTALL_FILES)
+
include $(top_srcdir)/automake/local.am