summaryrefslogtreecommitdiffstats
path: root/c/src/ada-tests/sptests/sp19/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'c/src/ada-tests/sptests/sp19/Makefile.am')
-rw-r--r--c/src/ada-tests/sptests/sp19/Makefile.am6
1 files changed, 2 insertions, 4 deletions
diff --git a/c/src/ada-tests/sptests/sp19/Makefile.am b/c/src/ada-tests/sptests/sp19/Makefile.am
index 36c64ad94b..5e81abe284 100644
--- a/c/src/ada-tests/sptests/sp19/Makefile.am
+++ b/c/src/ada-tests/sptests/sp19/Makefile.am
@@ -2,7 +2,6 @@
include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
include $(top_srcdir)/../../../automake/compile.am
-include $(top_srcdir)/../../../automake/lib.am
include $(top_srcdir)/ada.am
@@ -11,12 +10,11 @@ AM_ADAFLAGS += -I.
noinst_PROGRAMS = sp19
sp19_SOURCES = sp19.adb sptest.adb config.h sptest.ads
+sp19_SOURCES += ../../support/init.c
-sptest.adb: sptest.adp
- pwd=`pwd` && cd $(srcdir) && $(M4) < sptest.adp > $${pwd}/sptest.adb
CLEANFILES += sptest.adb
-sp19$(EXEEXT): sp19.adb sptest.adb sptest.ads
+sp19$(EXEEXT): sp19.adb sptest.adb sptest.ads init.$(OBJEXT)
$(GNATCOMPILE) -margs -a $< -o $@
EXTRA_DIST = sp19.scn