summaryrefslogtreecommitdiffstats
path: root/c/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'c/src/Makefile.am')
-rw-r--r--c/src/Makefile.am21
1 files changed, 21 insertions, 0 deletions
diff --git a/c/src/Makefile.am b/c/src/Makefile.am
new file mode 100644
index 0000000000..f5adbccd40
--- /dev/null
+++ b/c/src/Makefile.am
@@ -0,0 +1,21 @@
+#
+# $Id$
+#
+
+AUTOMAKE_OPTIONS = foreign 1.4
+ACLOCAL_AMFLAGS = -I $(RTEMS_TOPdir)/aclocal
+
+SUBDIRS= make exec lib tests
+
+rtems_bspdir=$(prefix)/@RTEMS_BSP@
+
+# NOTE: The wildcard on the install should pick up everything except
+# the tests directory. This significantly minimizes the install size.
+install-data-local:
+ rm -rf $(rtems_bspdir)/[bsl]*;
+ $(mkinstalldirs) $(rtems_bspdir)
+ cd $(PROJECT_ROOT); \
+ tar cf - @RTEMS_BSP@/[bilsuM]* | (cd $(prefix); tar xpBf - );
+
+include $(top_srcdir)/../../automake/subdirs.am
+include $(top_srcdir)/../../automake/local.am