summaryrefslogtreecommitdiffstats
path: root/testsuites/tmtests/tm30/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2010-06-21 16:53:50 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2010-06-21 16:53:50 +0000
commitf63801a25209817f751e4139c92ca9eb7bd35f05 (patch)
tree67206c4d723682dc0f0a4f05ef9a267d30f1fdcc /testsuites/tmtests/tm30/Makefile.am
parent2010-06-21 Peter Dufault <dufault@hda.com> (diff)
downloadrtems-f63801a25209817f751e4139c92ca9eb7bd35f05.tar.bz2
2010-06-21 Joel Sherrill <joel.sherrill@oarcorp.com>
* Makefile.am, configure.ac: New test for barrier create, ident, and delete. * tm30/.cvsignore, tm30/Makefile.am, tm30/init.c, tm30/tm30.doc: New files.
Diffstat (limited to 'testsuites/tmtests/tm30/Makefile.am')
-rw-r--r--testsuites/tmtests/tm30/Makefile.am29
1 files changed, 29 insertions, 0 deletions
diff --git a/testsuites/tmtests/tm30/Makefile.am b/testsuites/tmtests/tm30/Makefile.am
new file mode 100644
index 0000000000..d23db16f84
--- /dev/null
+++ b/testsuites/tmtests/tm30/Makefile.am
@@ -0,0 +1,29 @@
+##
+## $Id$
+##
+
+MANAGERS = io rate_monotonic semaphore
+
+rtems_tests_PROGRAMS = tm30
+tm30_SOURCES = init.c ../include/timesys.h \
+ ../../support/src/tmtests_empty_function.c \
+ ../../support/src/tmtests_support.c
+
+dist_rtems_tests_DATA = tm30.doc
+
+include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
+include $(top_srcdir)/../automake/compile.am
+include $(top_srcdir)/../automake/leaf.am
+
+OPERATION_COUNT = @OPERATION_COUNT@
+AM_CPPFLAGS += -I$(top_srcdir)/include -DOPERATION_COUNT=$(OPERATION_COUNT)
+AM_CPPFLAGS += -I$(top_srcdir)/../support/include
+
+LINK_OBJS = $(tm30_OBJECTS) $(tm30_LDADD)
+LINK_LIBS = $(tm30_LDLIBS)
+
+tm30$(EXEEXT): $(tm30_OBJECTS) $(tm30_DEPENDENCIES)
+ @rm -f tm30$(EXEEXT)
+ $(make-exe)
+
+include $(top_srcdir)/../automake/local.am